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ABBREVIATIONS

The following are the abbreviations used in this document.

IE

Internet Explorer

PDF

Portable Document Format

PKCS

Public Key Cryptographic Standards

S/MIME

Secure Multi-Purpose Internet Mail Extensions

Table 2: Abbreviations
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1. INTRODUCTION

Outlook Express supports Secure Multi-Purpose Internet Mail Extensions (S/MIME) standard. At the core
of any S/MIME client, the sender will find support for the Public Key Cryptography Standards (PKCS).
S/MIME clients use PKCS #7 Cryptographic Message Syntax, which defines the basic structure of the
digital signature and envelope.

Note: If the sender have multiple mail accounts configured in his/her Outlook Express, the sender will
need a separate certificate for each one because each certificate is tied to a unique email address.
Outlook Express automatically selects the correct certificate based on the account the sender uses to
send messages.

1.1. Purpose

The purpose of the document is to explain the usage of digital certificates in Microsoft Outlook Express.
1.2. Scope

The scope of the document is restricted to usage of digital certificates in Microsoft Outlook Express 6.0.

This is an indicative document for configuring Microsoft Outlook Express 6.0. The document may be
adopted for higher or lower Microsoft Outlook versions.
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2. MAIL ACCOUNT SECURITY SETTINGS

Following steps will enable signing and encryption of all the outgoing messages from the sender’s
account.

Note: To enable signing and encryption, senders account should install the chain certificates in IE
browser.

2.1. Sign Outgoing Messages Settings

Outlook Express includes the option to digitally sign all the outgoing messages. This section lists the
steps to be followed in order to set the options to sign all outgoing messages.

Select ‘Options’ from the Tools menu.

Select the ‘Security’ tab of the Options dialog.

Check ‘Digitally sign all outgoing messages’. Refer Figure 1: Sign Outgoing Messages.
Click on OK to close the ‘Options’ dialog.

General Read Receipts Send Compoze Signatures
Spelling Security Connection M aintenance

P wnNe

Wirug Protection

Select the Internet Explarer zecurity zone bo use;
(®)intemet zone [Less secure, but more funchionall
) Restricted sites zone [More secure)

[]'wfarn me when other applications ty to gend mail as me.

[] Do nat allow attachments to be zaved or opened that could
patentially be a wis,

Download Images
[]Elock images and other external content in HT ML e-mail

Secure b ail
Digital 1Dz [alzo called certifizates] are special
% docurments that allowe pou to prove your identity in
electronic trangactions. Digital [D's..
Tao digitally sign messages or receive encrypted
meszages, you must have a digital (D Get Digital 1D...

[]Encrypt contents and attachments for all outgaing messages
Dhigitally zign all outgoing meszages
Advanced...

I OF. l [ Catcel

Figure 1: Sign Outgoing Messages
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5. Follow the steps below, to enable the option to attach digital certificate with the outgoing
message:
a. Select ‘Options...” from the Tools menu.
b. Select the ‘Security’ tab of the Options dialog.
c. Click the ‘Advanced’ button in the same dialog box. Refer Figure 2: Advanced Security
Settings.
d. Check the option, ‘Include my digital ID when sending signed messages’.

By attaching digital certificate with the message, receivers can verify the message even if they
don’t have the sender’s certificate.

Advanced Security Settings

Encrypted messages
% Wwiarn on encrypting meszages with lezs than this strength;

28 hitz W

Always encrypt to myzelf when zending encrypted mail

Digitally Signed messages

R Inchude my digital [0 when sending signed meszages
[ ]Encode mezzage before signing [opagque sighing]
Add zenders’ certificates to my address book.

R evocation Checking

% Check for revaoked Digital [Ds;
(%) Only when online

() Mever

] l [ Cancel

Figure 2: Advanced Security Settings
While sending mails if the sender’s digital certificate does not exist, Outlook will warn that the message
cannot be signed and prompt if the user wants to send an unsigned message.
2.2. Choose Valid Certificates Settings

This section lists the steps to be followed in order to set the options to choose valid certificates.

1. Select ‘Internet Accounts...’ from the Tools menu. Refer Figure 3: Internet Accounts.
2. Select the Mail tab of the Accounts dialog.
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Internet Accounts

All | M ail | Mews | Directory Service Add »
Account Type Connection Remove

@ dohatec mail il Local Area Metwark,

L asib dohates mal RuEllEE el Lacal frea Metwork amGREILES

Set gz Default
Impart....

Export...

Set Order...

Cloze

Figure 3: Internet Accounts

3. Select mail account and select ‘Properties’ for that account for which the sender has obtained
Digital Certificate. Refer Figure 4: Account Properties.
4. Select the ‘Security’ tab of the Properties dialog.

*E hasib dohatec mail Properties

General | Servers I:::unnectiu:un| Security | Advanced

Signing certificate

Select the signing certificate below. This will determine the digital
|0 uged when signing messages with thiz account.

Certificate: Hazib Hazan Md | [ Select. ..

Encrypting preferences

Select the encryption certificate and algorithm. Thesze are
included with wour digitally zigned meszsages =0 others can zend
encrypted mail to pou with these settings.

Certificate: | | Select...

Mlgoithm: | 3DES v|

(] 8 ] [ Cancel Apply

Figure 4: Account Properties
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5. Click on the Signing Certificate. Click ‘Select...” button.

6. Select the certificate the sender wants to use, then click on OK. Refer Figure 5: Certificate
Selection.

Select Default Account Digital ID

Select the certificate you wank ko use,

Issued to Issued by Intended P...  Friendly na... | Expiration ...

E9 Hasib Ha... UAT C& <All= Mone Zlafz2014

<

| ¥

(0]4 H Canicel H Wieww Certificate ]

Figure 5: Certificate Selection
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3. SIGNED AND ENCRYPTED MESSAGES

The following sections lists the steps to be followed, in case the sender does not want to activate the
option to sign and encrypt all outgoing messages but wants to sign certain outgoing messages.

3.1. Send Signed Message

The sender has the option of signing the message to authenticate to the receiver, the identity of the
sender. Here the private key of the sender is used to sign the message and a copy of the digital
certificate (containing the public key of sender) is sent along with the message.

1. Create a new email by clicking on the ‘New Mail’ button.

2. The ‘New Message’ composition window will open.

3. Click on the ‘Sign’ button in the menu bar or select the ‘Digitally Sign” item from the Tools menu.
Refer Figure 6: Signing Message.

=3
'l‘Ir

© Fle Edt ‘iew Insert Format  Toals  Message  Help

= | X% L & T 0 ¥

Send Undo Check.  Speling Attach  Priority

s x]

gervpt  Offline

Toi  |eahidul@dohater net; 2

[ C: |
Subject: |Test

|
11
nt
s
1'll
[y
[t
Il

|F\ria| v||1|:| v| :v B 7 UA,

Hello warld|

Figure 6: Signing Message

When the sender sends a signed email, the sender’s private key is used to digitally sign the message.
When the sender clicks ‘Send’ button, depending on the private key security level, which is established
while the sender first installed the sender’s personal digital certificate, the sender may receive either an
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‘OK/Cancel’ prompt or a prompt asking for the sender’s private key password. If the sender selected a
private key security level of "Low", the message will be sent without warnings or prompts.

3.2. Send Encrypted Message

The sender can send encrypted email to anyone who has a digital certificate. When the sender’s
correspondent sends a signed email or the certificate file as an attachment to the sender, the sender’s
email program will store the correspondent’s digital certificate in the sender’s email address book.

Once the sender has that correspondent’s digital certificate in the sender’s email address book, the
sender can encrypt all email to the correspondent by clicking on the encrypt button.

1. Create a new email by clicking on the ‘New Mail’ button.
2. The ‘New Message’ composition window will open.

3. Click on the ‘Encrypt’ button in the menu bar or select the Encrypt item from the Tools menus
shown below. Refer Figure 7: Encrypt Message.

B Test

. Fle Edt View Insert Format  Tools  Message Help f
. AB —
= oo E) ﬁ" j lﬂ l', - =
Send lUndo Check  Spelling Attach  Priority Ffline
Ta: |zahidu|@dnhatec.net; o ﬁ
|

Subject: |Test

Iilh
(]
|
ol

|.C\rial v||1l:| v| :T B 7 UA = = &=

Hello world

Figure 7: Encrypt Message

The sender is only able to encrypt this email if the sender has the public key of the receiver. If the
sender attempts to send an encrypted email to someone for whom the sender does not have a public
key, Outlook Express will warn the sender that it is not possible and prompt the sender to send the mail
unencrypted or not to send the mail.
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3.3. Receive Signed and Encrypted Messages

While receiving signed message from others, the receiver can right click on the ‘From’ name at the top
of the message and can add that particular digital certificate to the address book. When this is done, the
certificate and public key information is stored in the address book and the sender will be now able to
send encrypted email to this person.

When the user receives a signed message, Outlook Express uses the public key attached with the
message to verify the signature.

When the sender receives email, which is signed, and/or encrypted, the message will have the
appropriate icon attached to it. The following is a typical signed mail. Refer Figure 8: Receive Signed
Message.

: File Edit Wew Insert Format  Tools  Message Help 3
E - AR = .
3 % D & J 0 V. =2 =2 5%
© Send Undo Check  Spelling Attach  Priority Sign Encrypt  OFfline
To: |zahidul@d0hatec.net; ®
(e |
Subject: |Test
|.°.ria| v| |IU y| :v B 7 O A' = = ';: *;: =SS B . [e]
Hello world|

Figure 8: Receive Signed Message

The red icon in Figure 8: Receive Signed Message indicates that the message is a sighed message.
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B Test

File Edit ‘View Insert Format Tools Message Help -:,'
= v AB - .
2% 0D YW %% T 0 V.5 =35
Send Undao Check  Spelling Attach  Priarity Sign Encrvpt | Cffline
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Subject: |Test
| il VoW E|B Z UA|SESEFEIEESE| - @
Hello world

Figure 9: Receiving Encrypted Message

The blue padlock in Figure 9: Receiving Encrypted Message indicates that it is an encrypted mail. The
receiver can click on these icons to examine the details of the certificate used to sign and/or encrypt the

message.
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4. MANAGE DIGITAL CERTIFICATES

The following sections provide the information regarding the management of digital certificates with
Outlook Express.

4.1. Store Correspondent’s Digital Certificate

Sending an encrypted message to a correspondent requires the sender to have a copy of their digital
certificate. The easiest way to get a copy of someone’s digital certificate is to get the correspondent to
send a digitally signed message, in case the encryption and signing certificates are the same. Else the
correspondent may send the certificate attached to the mail. To store a contact’s digital certificate:

Open the signed message from Outlook Express.
From the ‘File’ menu select ‘Properties’.

Click the ‘Security’ tab.

Click ‘View Certificates’.

Click the ‘Add to Address Book’ button.

ukhwnNeE

4.2. Import Digital Certificate

To import someone’s digital certificate that exists in the directory or on the user’s hard-drive, download
the digital certificate, and add it to the Outlook’s address book:

1. Selectan address

2. Choose ‘File’ from the main menu then ‘Properties’. Click the ‘Digital Ids’ tab.
3. Click the ‘Import’ button. Refer Figure 11: Importing Digital Certificate.

4. Search for the digital certificate file and click Open.
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Internet Accounts
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Figure 10: Importing Digital Certificate
4.3. View Digital Certificate

To view details of receiver’s digital certificate:

1. Open the ‘Address book’ (Tools > Address Book) and double click on the correspondent entry.
2. Select the ‘Digital Ids’ tab in the Properties dialog box.
3. Select the Digital Certificate that user wants to view and click the ‘Properties’ button.

4.4. Delete Digital Certificate
To delete a digital certificate from address book:

1. Open the ‘Address book’ (Tools > Address Book) and double click on the entry that the sender
would like to view.

2. Select the ‘Digital Ids’ tab in the ‘Properties’ dialog box.

Select the Digital Certificates that user want to remove and click the ‘Remove’ button.

4. Deleting a correspondent’s digital certificate will mean the sender will be no longer able to send
encrypted mail to that contact.

w
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